jueves, 26 de junio de 2014

Chromium perdió Flash, ¡encuéntralo de nuevo!

Como ya sabéis, con la llegada de la versión 35 de Chromium, se puso fin al soporte para plugins NPAPI y solo se soporta el nuevo estándar PPAPI, con lo cual, al no existir un plugin de Java PPAPI, este deja de funcionar en Chromium

Pero una víctima colateral a esto es el plugin PPAPI más famoso. ¡Flash deja de funcionar para muchos usuarios de Chromium!


Bueno, en realidad no es que Flash deje de funcionar, es sencillamente que si tenías tu equipo funcionando desde hace un tiempo, como es mi caso, seguramente el plugin que en su momento instalaste es el basado en NPAPI, que en su momento daba servicio igual a Iceweasel y a Chromium, pero que ahora no es reconocido por el segundo.

Sin embargo, al contrario que con Java, la solución es rápida, sencilla y viene de los propios repositorios de Debian. ¿No imaginas cuál es? Pues se trata sencillamente de instalar el plugin PPAPI de Flash, de una manera análoga a como se venía haciendo con su hermano NPAPI.

El plugin está disponible en los paquetes non-free tanto para Jessie y sid como para Wheezy, aunque para este debamos tener configurados los repositorios wheezy-backports.  

La instalación es sencilla, basta con pasarnos por Synaptic y buscar e instalar el paquete pepperflashplugin-nonfree. Si lo prefieres, puedes hacerlo en la terminal de un golpe de comando.
  • sudo aptitude install pepperflashplugin-nonfree

Este paquete se encarga de descargar Chrome sin instalarlo, extraer el plugin de Flash que contiene y hacerlo disponible para Chromium. Todo automáticamente y sin que tengas que preocuparte por nada.



Y con esto tu Chromium volverá a disponer de Flash y ademas ¡actualizado!

8 comentarios:

  1. Una perlita: pepperflashplugin-nonfree tiene como "sugerido" el paquete hal. Recomiendo no instalar dicha sugerencia por lo siguiente https://wiki.debian.org/hal
    La instalación de hal causa problemas con algunos periféricos, sobre todo, con algunos discos.
    JAP

    ResponderEliminar
    Respuestas
    1. A mi con Synaptic no me dijo nada de hal

      Investigaré un poco mas

      Gracias por el aviso

      Eliminar
    2. El paquete hal no esta en Jessie, por eso no me lo pide.

      En Wheezy si esta disponible, puede que ese sea el tema

      Eliminar
    3. Exactamente. Tengo tres máquinas corriendo Debian, una con "jessie" y dos con "wheezy". Las que están en "wheezy" presentan esa situación, si . Si lo instaló, se soluciona con un simple "apt-get purge hal". Eso, si uno tiene configuradas las sugerencias como dependencias, que es algo que si mal no recuerdo, viene por defecto en synaptic.
      JAP

      Eliminar
  2. Menos mal que lo tengo instalado en Debian Wheezy, aunque Opera Developer jala el Pepper Flash Player dierctamente de Chrome.

    Y por cierto, Adobe hasta ahora no ha mencionado nada al respecto si va a distribuir el Pepper Flash Player para Chromium.

    ResponderEliminar
    Respuestas
    1. De momento, parece que los plugin de ppapi se limitan a los dos que trae Chrome, que son el lector pdf y flash

      Eliminar
  3. Hola! lamentablemente, al intentar lo que recomiendas, resulta en:
    "aptitude install pepperflashplugin-nonfree
    No se puede encontrar ningún paquete cuyo nombre o descripción coincida con "pepperflashplugin-nonfree"
    No se puede encontrar ningún paquete cuyo nombre o descripción coincida con "pepperflashplugin-nonfree"
    No se instalará, actualizará o eliminará ningún paquete.
    0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
    Necesito descargar 0 B de ficheros. Después de desempaquetar se usarán 0 B."
    Alguna idea que me sea de ayuda? saludos y gracias! Ceci

    ResponderEliminar
    Respuestas
    1. El paquete esta en los repositorios, en la seccion "contrib"

      https://packages.debian.org/jessie/pepperflashplugin-nonfree

      Si usas Wheezy, tienes que tener los backports

      Eliminar

prekes sodui